[Mailman-Users] [bin/check_perms -f] - dont work...

jbrouhard at ci.st-joseph.mo.us jbrouhard at ci.st-joseph.mo.us
Wed May 21 15:19:10 CEST 2003

I believe I can help with this.

To use the ports system to install openssl:

as root...

cd /usr/ports/security/openssl ; make install

That will install the OpenSSL Port for FreeBSD... I recommend running CVSup
before doing this to make sure you have a recent snapshot of the ports
tree.. it's updated almost daily.

Joe Brouhard, MCP, A+
Computer Support Technician
City of St Joseph
jbrouhard at ci.st-joseph.mo.us

-----Original Message-----
From: Richard Barrett [mailto:r.barrett at openinfo.co.uk]
Sent: Tuesday, May 20, 2003 3:06 PM
To: Kristian Wind
Cc: mailman-users at python.org
Subject: Re: [Mailman-Users] [bin/check_perms -f] - dont work...

At 20:32 20/05/2003, Kristian Wind wrote:
>Hi all!
>Very (!!!) new til Mailman, but...
>Running FreeBSD 4.7 and the Pyhon 2.2.2_2 FreeBSD port, and are trying to 
>install Mailman 2.1.2. The first thing I tried was installing the Mailman 
>port vers. 2.1.1 but got some errors. Then I tried to install the source 
>version 2.1.2 and extract and compile it according to the instructions. 
>But still got the errors when running the "bin/check_perms -f" command. 
>Running bin/check_perms -f several times does not help.
>root at bsd /usr/local/mailman $> bin/check_perms -f
>Traceback (most recent call last):
>   File "bin/check_perms", line 369, in ?
>     checkmta()
>   File "bin/check_perms", line 300, in checkmta
>     __import__(modname)
>   File "/usr/local/mailman/Mailman/MTA/Manual.py", line 23, in ?
>     from Mailman import Message
>   File "/usr/local/mailman/Mailman/Message.py", line 25, in ?
>     import email.Message
>   File "/usr/local/mailman/pythonlib/email/Message.py", line 15, in ?
>     from email import Utils
>   File "/usr/local/mailman/pythonlib/email/Utils.py", line 8, in ?
>     import socket
>   File "/usr/local/lib/python2.2/socket.py", line 41, in ?
>     from _socket import *
>ImportError: Shared object "libssl.so.3" not found

Your problem is not a Mailman problem.

You will get the same problem if you run python from the command line and 
enter the Python statement "import socket".

The Python you have installed was configured to expect support for SSL.

The error is saying that a shared library that Python's socket module is 
expecting to find is not present i.e libssl.so.3.

This is probably part of the openssl package.

But being as I do not use FreeBSD I cannot help any further.

>One thing I might have done wrong was installing as root?
>I have NO idea whatsoever what to do. Please advise...
>(I'm on digest, so please copy me on kristian at moni2r.dk)
>Thanks in advance...
>Venlig hilsen / Best regards
>Kristian Wind
>Monitor - Skolegade 7b - DK8000  Aarhus C
>T: 70222940 - F: 70222960 - M: 40330685
>kristian at moni2r.dk - http://www.moni2r.dk

Richard Barrett

More information about the Mailman-Users mailing list