[Mailman-Users] group trouble

Sven Esbjerg esbjerg at xbsd.net
Wed Oct 1 11:24:48 CEST 2003

I have recently installed mailman 2.2.1 on an OpenBSD 3.3 Sparc64 server.
When I send mail to a test list mailman complains that postfix is executing
the mailman script with the wrong group. The message is:

"/usr/local/lib/mailman/mail/mailman bounces gl4". Command output: Group            
    mismatch error.  Mailman expected the mail wrapper script to be executed as         
    group "nobody", but the system's mail server executed the mail script as            
    group "mailman".  Try tweaking the mail server to run the script as group           
    "nobody", or re-run configure,  providing the command line option                   

However mailman was installed with ./configure --with-mail-gid=nobody which
is the ports way on openbsd. I tried changing the --with-mail-gid= to use
mailman. This results in mailman complaing that the script was executed with
group nobody but it expected mailmani - the opposite as before.
I have tried changing the group permissions on the alias files to match the
complaint (after reading the archives). This didn't change a bit.

I'm at loss here. Could somebody give me a hint on how to solve this?

Sven Esbjerg
CPH Denmark
http://www.usenet.dk/netikette - på forhånd tak.

More information about the Mailman-Users mailing list