[Mailman-Users] Lists not showing up in listinfo page, (yup I read the FAQ.)

mettius mettius at tol-lamfirith.org
Sun Apr 11 21:07:06 CEST 2004

Before you flame, I've read the FAQ and noted the section on this
symptom. But it hasn't addressed my problem.

If you hit this URI: http://cactusairforce.org/mailman/listinfo
You see all lists (including Mailman?!)

but if you instead hit this one:
you only see the CAF and the Recruitment_list

>From the FAQ:
"1. the value of the list's 'advertised' option (the first one on the
page) of the Privacy Options Section of the list's admin web GUI."

This isn't the problem.

"2. the value of VIRTUAL_HOST_OVERVIEW in $prefix/Mailman/Defaults.py or
mm_cfg.py. If this is set to true (usually 1) then you may be
experiencing the effect of Mailman Virtual Host feature. In that case
the address in the URL used to access listinfo is compared to the
address in the list's 'web_page_url' option (the last one) of the
General Options Section of the list's admin web GUI. If they are not the
same, the list is not added to the listinfo page returned."

If I change this value in Defaults.py (it doesn't appear in mm_cfy.py)
to "0", I *can* see all of the lists, unfortunately it also displays all
the lists from the other (non virtual) domain on this server.

Also, I've checked in the GUI, there is no entry for 'web_page_url'
there is one for 'host_name' but this is set for cactusairforce.org (in
all the lists).

Distro: SuSE Pro 8.2, (x86)


More information about the Mailman-Users mailing list