[Mailman-Users] "Failure to find group name" error

Paul Bromiley paul.bromiley at man.ac.uk
Tue Aug 17 21:52:40 CEST 2004


I am trying to set up Mailman on a Fedora Core 2 system running apache 2.0, 
using the Mailman 2.1.5 tarball downloaded from www.list.org.  I have 
followed the installation instructions, and used

configure --with-mail-gid=mail --with-cgi-gid=apache

at the configuration stage.  These group names are the correct ones for 
sendmail and apache on my system (i.e. the ones given in httpd.conf and 
sendmail.cf).  The installation proceeds without any errors, and when I set 
up the site-wide mailing list I get a confirmation e-mail stating that I can 
configure the mailing list at  http://......../mailman/admin/mailman.  
However, when I point my web browser at that page I get:

Mailman CGI error!!!

The Mailman CGI wrapper encountered a fatal error. This entry is being stored 
in your syslog: 
Failure to find group name apache.  Try adding this group
to your system, or re-run configure, providing an
existing group name with the command line option --with-cgi-gid.

The apache group exists on my system (i.e. it is listed in /etc/group) and 
works properly: I can chown files to this group.  I have also tried running 
configure with the group ID numbers instead of the names, but get the same 

I know that this question has been posted before, but none of the posts in the 
archives describe what you have to do to fix it.  Any help you could give me 
would be greatly appreciated.


More information about the Mailman-Users mailing list