[Mailman-Users] Exim Filters - local_suffix Problem

Lloyd Tennison lists at viplist.us
Mon Aug 30 23:18:47 CEST 2004

I have been trying to figure this out for a couple of weeks now, got some help, but nothing seems to work.  I wish to forward bounce messages that come in from Mailman to both the Mailman processor and another local account.  I have tried using the filter as per Exim Spec. 42.7

    driver = redirect
    file = $home/.forward
    local_part_suffix = -*

It runs a user's .forward file for all local parts of the form *username-**. Within the filter file the user can distinguish different cases by testing the variable $local_part_suffix. For example: 

  if $local_part_suffix contains -special then
    save /home/$local_part/Mail/special

by both the given example and  and by substituting a "deliver me at mymail.com" in place of the save command.  I am also set an absolute path "/home/user/mail/special". Any way I try it, I always receive: unable to set gid=32044 or uid=32043 and mailman_userforward router (recipient is catchall at servername.com): failure to transfer data from subprocess: status=0100 readerror='No such file or directory' - when the file directory does exist.

I cannot try to test local (using exim -d ) as since that is a local account the routers treat differently.  I have tried using vfilers - but it never seems to get there - because of the local domain issue. It also seems that I cannot do a -d-all in the startup daemon - as it looks like Cpanel does not compile with the debug option on - as no debug info shows up and the daemon shows it being run.

I have set permissions to 644 and gave owner/group to owner/owner, owner/mail and owner/nobody.  I have tried putting quotes around the match, i.e. special in this example and have tried doing a match on $local_part.  All give the same response.

Any help would be appreciated.  I do not even have to do it this way - just any way that will work.

Oh, I have removed the -bounces from the mailman_virtual_router - otherwise the message would never go anywhere other than to mailman's command structure through the special mailman_virtual_transport.  If could have transport point (go to) both a command and a local account, that would also solve my problem.

More information about the Mailman-Users mailing list