[Mailman-Users] group mismatch error

Sean Butler sean at 2sparrows.org
Thu Feb 5 17:10:55 CET 2004

At 02:43 PM 2/4/2004, Sean Butler wrote:

>Here is the error I continue to get, no matter what I try:
>Feb  4 14:37:10 east postfix/local[77072]: 0EC763E4B: 
>to=<church at 2sparrows.org>, relay=local, delay=0, status=bounced (Command 
>died with status 2: "/usr/local/mailman/mail/mailman post church". Command 
>output: Group mismatch error.  Mailman expected the mail wrapper script to 
>be executed as group "daemon", but the system's mail server executed the 
>mail script as group "mailman".  Try tweaking the mail server to run the 
>script as group "daemon", or re-run configure,  providing the command line 
>option `--with-mail-gid=mailman'. )
>Here is what I have done since I first started getting this:
>1.  make deinstall; make --with-mail-gid=mailman; make instll
>         still same problem
>2.  modified the /usr/local/mailman/mail/mailman file to look like
>     this:
>         -rwxrwsr-x  1 root  mailman  18504 Feb  3 16:16 mailman
>     It was group dameon before.  After the change, I still get the
>     same errors.
>3.  Ran check_perms with a -f:
>         directory permissions must be 02775: 
> /usr/local/mailman/lists/church (fixing)
>        /usr/local/mailman/mail/mailman bad group (has: daemon, expected 
> mailman) (fixing)
>      Still the same error as above.
>check_perms now shows no errros, yet I still can't send mail to 
>church at 2sparrows.org.
>Any ideas?

So I'm a bit further.  I figured out how to set the MAIL_GID variable with 
make finally.  (FreeBSD ports installation.)

And now, I've created a list and have sent mail to it, but nothing seems to 

Logs show:

Feb  5 10:57:28 east postfix/qmgr[91727]: 3F5FA3E53: 
from=<sean at 2sparrows.org>, size=536, nrcpt=1 (queue active)
Feb  5 10:57:29 east postfix/local[12138]: 3F5FA3E53: 
to=<church at 2sparrows.org>, relay=local,
delay=1, status=sent ("|/usr/local/mailman/mail/mailman post church")

What now???


and a couple of minutes later:

Feb  5 11:00:00 east /usr/sbin/cron[12171]: (mailman) CMD 
(/usr/local/bin/python -S /usr/local/mailman/cron/gate_news)

But then nothing ever get's sent to the list.


More information about the Mailman-Users mailing list