[Mailman-Users] OS X 10.3 mailman/postfix woes

Chris Menzel cmenzel at tamu.edu
Sun Jan 25 00:54:16 CET 2004

I'm using Mailman 2.1.3 and just upgraded from OS X 10.2 to 10.3.2 (Panther).
Mailman was working splendidly under 10.2, but with the switch from sendmail to
postfix that 10.3 foists upon its users, I seem to be caught in a catch 22.  

If I set the smptd line in postfix's master.cf to my IP, i.e.,

nnn.nnn.nnn.nnn:25 inet n - n -  - smtpd

I can send and receive mail, but mailman won't deliver mail that has been sent
to any mailing lists; it just sits in the queue.  Yes, qrunner *is* running.
The mailman smtp log yields a rather obscure error of the following sort when
qrunner does its thing:

Jan 24 17:19:03 2004 (14880) All recipients refused: (61, 'Connection refused')
Jan 24 17:19:03 2004 (14880) All recipients refused: please run connect() first
Jan 24 17:19:03 2004 (14880) <20040124231647.GE14114 at tamu.edu> smtp for 3 recips, completed in 0.044 seconds

If, on the other hand, I replace the above line with 

localhost:25 inet  n - n -  - smtpd

then mailman delivers queued list mail properly, and mail generally can be
sent, but my machine will no longer *receive* any mail other than mail sent
from local accounts to themselves.  Interestingly, mail.log is just silent in
this case; it does not record that mail is being rejected.

I have spent many hours adjusting config files and reading usenet posts to no
avail.  I suspect the solution is very simple -- some line in a config file --
but I can't find it.  I *have* tried changing the last line of mm_cfg.py
variously to 

SMTPHOST = 'localhost'
SMTPHOST = '<my IP>'

and even tried getting around the problem with

SMTPHOST = 'mail.tamu.edu' (the local university wide server)

All failed to solve the problem, of course.  Any help would be most

Chris Menzel

More information about the Mailman-Users mailing list