[Mailman-Users] Problems with news2email gateway after upgrading from 2.1.2 to 2.1.5

Brad Knowles brad.knowles at skynet.be
Wed Jun 2 01:52:09 CEST 2004

At 1:38 PM -1000 2004/06/01, Eric McDonald wrote:

>  Jun 01 14:50:12 2004 gate_news(27744): Traceback (most recent call last):
>  Jun 01 14:50:12 2004 gate_news(27744):   File 
>"/usr/local/mailman/cron/gate_news", line 284, in ?

	Mailman 2.1.x doesn't use cron anymore.  The fact that "cron" 
appears in this URL would seem to be an indicator that you are 
upgrading from version 2.0.x to 2.1.5, not 2.1.2 to 2.1.5.  Is that 

>  Jun 01 14:50:12 2004 gate_news(27744): AttributeError :  'module' 
>object has no attribute 'nntpsplit'
>  Jun 01 16:33:04 2004 (6937) Uncaught runner exception: 'str' object 
>has no attribute 'get_sender'
>  Jun 01 16:33:05 2004 (6937) Traceback (most recent call last):
>    File "/usr/local/mailman/Mailman/Queue/Runner.py", line 111, in _oneloop
>      self._onefile(msg, msgdata)
>    File "/usr/local/mailman/Mailman/Queue/Runner.py", line 159, in _onefile
>      sender = msg.get_sender()
>  AttributeError: 'str' object has no attribute 'get_sender'

	You don't tell us anything about the OS you're using, what 
version of Python  you have, etc....  However, I would ask if you've 
seen the FAQ entry at 

Brad Knowles, <brad.knowles at skynet.be>

"They that can give up essential liberty to obtain a little temporary
safety deserve neither liberty nor safety."
     -Benjamin Franklin, Historical Review of Pennsylvania.

   SAGE member since 1995.  See <http://www.sage.org/> for more info.

More information about the Mailman-Users mailing list