[Mailman-Users] News -> Mail: no mail! (repost)

NFN Smith worldoff9908 at sacbeemail.com
Wed May 5 23:40:42 CEST 2004

I posted this one last week, but no response, yet.  Any takers on this
one?  I thought this was a fairly simple one -- or is it just




I'm in the process of setting up a server with the following:

- Fedora Core 1
- Mailman 2.1.4
- Sendmail 8.12.10
- INN 2.3.5

Mailman, Sendmail and INN all have been installed from the .RPM
bundled with Fedora.

I'm doing this setup as an internal server, so I'm not exchanging
traffic with the Internet at larger.

Where I currently am is that I have Mailman working fine as a mailing
list server, and no problems at all with INN as a news server.  I also
am not having any difficutly of getting mail to news.

However, where I am having difficulties is in getting messages
composed in news back to mail.  In my mailman configs, I'm pretty much
running with default settings -- in fact, the only things I'm
specifying in my mm_cfg.py are the necessary settings for the server name.

I do have all the supplied activities running in the mailman user's
crontab, and those are running on the specified schedules.

The specific place where I'm having problems is when I run gate_news,
I'm getting no response, other than a single log entry in /var/log/cron:

Apr 27 15:00:01 bronze CROND[12436]: (mailman) CMD (/usr/bin/python -S

If I run gate_news from a shell prompt, I get a pause for a few
seconds, and then a new prompt, but no other output.

I've checked all of my logs, including /var/log/maillog and
/var/log/mailman/*, and there are no updates to any of these logs
following gate_news runs.

I also checked all the steps in the troubleshooting section (3.14) of
the Mailman FAQ.  The only thing that turned up other than what should
be is that that a check_perms check showed that the permissions of the
files in /var/mailman/qfiles were incorrect.  On the advice of
check_perms, I ran 'chmod 02775 *' on the directory.  (These files
have owner:group set to:  mailman:mailman ).  I then restarted all the
mailman services by rebooting the machine.  Following that, I'm still
having the same behavior.

What I'm missing has to be something small, but I'm not seeing it.
Any clues?

Thanks in advance.


Composed by sacbeemail.
Get Your Free E-mail at http://www.sacbeemail.com . Or visit Northern California’s premiere news and information website at http://www.sacbee.com .

More information about the Mailman-Users mailing list