[Mailman-Users] archive link returns a 404

Mark Sapiro msapiro at value.net
Mon Nov 29 17:56:03 CET 2004

R DeWald wrote:

>When I click the archive link from my admin or general information pages 
>it returns a 404:
>"The requested URL /pipermail/eat/ was not found on this server."
>The list name in this example is "eat," by the way.  I have a feeling
>this is an apache redirect issue, a mm_config mistake or something
>similarly brain-dead, I am getting the same result for all lists on this
>server.  I have tried the faq wizard, but apparently I am equally
>incompetent there.

>From the INSTALL document:

    - Configure your web server to point to the Pipermail public
      mailing list archives:

      For example, in Apache:

         Alias /pipermail/ $varprefix/archives/public/

      where $varprefix is usually $prefix unless you've used the
      --with-var-prefix option to configure.

      Consult your web server's documentation for details.  Also be
      sure to configure your web server to follow symbolic links in
      this directory, otherwise public Pipermail archives won't be
      accessible.  For Apache users, consult the FollowSymLinks

The next few paragraphs of the document will be of interest if you're
going to be supporting internationalized public archives.

Note that $varprefix|$prefix needs to be replaced with the actual path.

Mark Sapiro <msapiro at value.net>       The highway is for gamblers,
San Francisco Bay Area, California    better use your sense - B. Dylan

More information about the Mailman-Users mailing list