[Mailman-Users] Has anyone successfully installed Mailman onFedora Core 2?

Brad Knowles brad at stop.mail-abuse.org
Tue Nov 30 11:41:04 CET 2004

At 1:03 PM +0900 2004-11-30, Stephen J. Turnbull wrote:

>    AC_CHECK_HEADER(Python.h, , got_python_h=yes)])
>    if test $got_python_h != yes -a $os = linux; then
>      echo 'If you're on Linux, you have the "binary distro no -devel 
>rpm" bug!'
>      echo 'Switch to an Industrial-Strength OS such as NetBSD immediately!'
>      echo 'Gentoo Linux will do, too.'

	But then you have to do this for every OS in existence.  You'd 
have to wrap a conditional of this sort around every single file that 
building Mailman might require, but which is not included as part of 
Mailman itself.

	I'm sorry, but this is a totally non-scalable suggestion.  If all 
we had to do was to support a single OS, that would be fine.  But we 
can't do everyone's job for them, and if the RPM builders want to 
have multiple different versions of Python (or whatever else Mailman 
might depend on), then they need to take the responsibility of 
dealing with the resulting issues.

Brad Knowles, <brad at stop.mail-abuse.org>

"Those who would give up essential Liberty, to purchase a little
temporary Safety, deserve neither Liberty nor Safety."

     -- Benjamin Franklin (1706-1790), reply of the Pennsylvania
     Assembly to the Governor, November 11, 1755

   SAGE member since 1995.  See <http://www.sage.org/> for more info.

More information about the Mailman-Users mailing list