[Mailman-Users] More help - please
brad at stop.mail-abuse.org
Tue Oct 5 22:26:39 CEST 2004
At 3:52 PM -0400 2004-10-05, John Dennis wrote:
>> I don't know if this is the only problem, but Python 2.3 is
>> required for use with Mailman 2.1.5. See
> Either that FAQ entry is misleading or not quite true (no pun intended
> :-). It seems to suggest that the need for python 2.3 comes from
> unresolved symbols True and False. But according to the python doc (see
> below) the symbols were added in 2.2.1 but with a different type, but it
> should still work.
I can't tell you the precise internal Python reasons, but my
understanding is that version 2.3 is required for use with Mailman
> We (Red Hat) have several distributions that have
> 2.2.x installed and successfully run mailman 2.1.5. Perhaps I've
> misinterpreted 2.3 requirement issue cited in the FAQ.
This may or may not work, depending on a variety of factors.
Operation of Mailman 2.1.5 with anything less than Python 2.3 may or
may not fail at any given time, depending on the particular path of
execution you're following through the code. Unless you want to make
source code modifications every time your Mailman installation dies
due to yet another place where certain assumptions being made by the
code were violated, you need to upgrade to Python 2.3.
Using anything older is officially unsupported.
At least, that's my understanding.
Brad Knowles, <brad at stop.mail-abuse.org>
"Those who would give up essential Liberty, to purchase a little
temporary Safety, deserve neither Liberty nor Safety."
-- Benjamin Franklin (1706-1790), reply of the Pennsylvania
Assembly to the Governor, November 11, 1755
SAGE member since 1995. See <http://www.sage.org/> for more info.
More information about the Mailman-Users