[Mailman-Users] Authorized Users

Jim Tittsler jwt at OnJapan.net
Thu Oct 7 01:36:57 CEST 2004

On Wed, Oct 06, 2004 at 10:02:48AM -0700, Robert Haack wrote:
> Ok, I got the patch and applied it and I checked the source files and 
> the patches are applied.  Then I tried it out and it didn't work so it 
> dawned on me that I need to compile it first.  I've tried to compile it 
> but I get the following error:

Normally you would apply it to the source of Mailman, and the
'make install' step would compile it for you.

> root at nclack Gui]# python -O GUIBase.py   (I've tried it with and without 
> the -O)
> Traceback (most recent call last):
> File "GUIBase.py", line 22, in ?
>   from Mailman import mm_cfg
> ImportError: No module named Mailman

I suspect you are applying it directly to your Mailman
installation.  The easiest thing to do would be to just remove
the old GUIBase.pyc file.  If the directory has mailman group
write permissions, the compiled file will be automatically
written the next time it is used.

(And remember to restart mailman patching.)

Jim Tittsler             http://www.OnJapan.net/      GPG: 0x01159DB6
Python Starship          http://Starship.Python.net/
Ringo MUG Tokyo          http://www.ringo.net/rss.html

More information about the Mailman-Users mailing list