[Mailman-Users] No mbox / No Archives

Mark Sapiro msapiro at value.net
Mon Aug 1 02:11:06 CEST 2005

Michael J McCafferty wrote:

>	I am using Mailman 2.1.5 with Postfix on CentOS 3.5 (RHEL 3). My problem 
>is that I have no archives. They are not being created.
>	Each list is set to archive, and to make the archives public. I do have 
>Apache set to follow symlinks.  I also do not have any mbox directories or 
>files being kept. I don't know why. I figure that I have no archives 
>because I have no mboxes.  I have checked the permissions (check_perms).
>	Any thoughts on how to remedy or what to check next ?

Are you using SELinux? There might be a security policy issue.

Normally, the list creation process creates the
archives/private/listname/listname.mbox/ directory and the first
archived message creates the
archives/private/listname/listname.mbox/listname.mbox file. It seems
that you have neither the directory or file for your lists. If you
create the directories by hand (in the 'mailman' group and group
writable and searchable and normally setgid although I don't think
that setgid is really necessary), that may allow messages to be
archived, but it doesn't answer the question of why the directories
weren't created in the first place.

There may be relevant messages in Mailman's 'error' log. Also, the
unarchived posts may be in the shunt queue such that creating the
directories and running bin/unshunt will archive those posts.

Mark Sapiro <msapiro at value.net>       The highway is for gamblers,
San Francisco Bay Area, California    better use your sense - B. Dylan

More information about the Mailman-Users mailing list