[Mailman-Users] Error during mailman runs

Mark Sapiro msapiro at value.net
Tue Aug 30 01:43:13 CEST 2005

Sean Roe wrote:
>I am getting the following errors durring mailman runs:
>mailman01:/var/lib/mailman/qfiles/out# Traceback (most recent call last):
>  File "/var/lib/mailman/bin/qrunner", line 270, in ?
>    main()
>  File "/var/lib/mailman/bin/qrunner", line 230, in main
>    qrunner.run()
>  File "/var/lib/mailman/Mailman/Queue/Runner.py", line 87, in run
>    self._cleanup()
>  File "/var/lib/mailman/Mailman/Queue/BounceRunner.py", line 220, in 
>    BounceMixin._cleanup(self)
>  File "/var/lib/mailman/Mailman/Queue/BounceRunner.py", line 132, in 
>    self._register_bounces()
>  File "/var/lib/mailman/Mailman/Queue/BounceRunner.py", line 120, in 
>    mlist.registerBounce(addr, msg, day=day)
>  File "/var/lib/mailman/Mailman/Bouncer.py", line 108, in registerBounce
>    info = self.getBounceInfo(member)
>  File "/var/lib/mailman/Mailman/MysqlMemberships.py", line 530, in 
>    row[2], row[0])
>TypeError: __init__() takes exactly 5 arguments (6 given)
>What does this mean?

It appears to be saying that the MysqlMemberships.py member adaptor
that you have installed is not compatible with your version of Mailman.

What Mailman version do you have?

What version of MysqlMemberships.py do you have (latest is 1.61,
2005-07-27)? See
and/or http://www.orenet.co.uk/opensource/

Mark Sapiro <msapiro at value.net>       The highway is for gamblers,
San Francisco Bay Area, California    better use your sense - B. Dylan

More information about the Mailman-Users mailing list