[Mailman-Users] Mailman not processing confirmations.

Matthew A. Marshall Matthew.Marshall at noaa.gov
Mon Feb 7 18:55:35 CET 2005

Matthew A. Marshall wrote:

> Mark Sapiro wrote:
>> Matthew A. Marshall wrote:
>>> Hello,  When subscribing to my mailing list via the web page, I see 
>>> in the maillog the message go out to the user.  When the user 
>>> responds with a confirmation, I see the message come in and sent to 
>>> the mailcmd.  However, after that, nothing happens.  The user 
>>> doesn't get subscribed nor is an emai dispatched telling the user 
>>> he/she has successfully subscribed.  Anyone else have these problems 
>>> or know what might be causing this?  I currently have the setting 
>>> for subscribing set to confirm.
>> Do you have
>> in mm_cfg.py? If so, perhaps there is a problem with some MTA/MDA along
>> the way dropping the confirmation token from the VERP like reply
>> address.
>> -- 
>> Mark Sapiro <msapiro at value.net>       The highway is for gamblers,
>> San Francisco Bay Area, California    better use your sense - B. Dylan
> Actually, no I don't have that in my mm_cfg.py.  This seems to be only 
> happening with requests.  Regular posts make it there just fine.
> Thanks!
> --Matt
I added that line to my mm_cfg.py and it came back with errors:

   ----- Transcript of session follows -----
Traceback (innermost last):
  File "/var/mailman/scripts/mailcmd", line 31, in ?
    from Mailman import MailList
  File "/var/mailman/Mailman/MailList.py", line 35, in ?
    from Mailman import mm_cfg
  File "/var/mailman/Mailman/mm_cfg.py", line 65, in ?
NameError: Yes
554 5.3.0 unknown mailer error 1

More information about the Mailman-Users mailing list