[Mailman-Users] Endless authentication on private archives... cookies set...

Eric D. Nielsen nielsene at MIT.EDU
Tue Jan 4 06:12:41 CET 2005

Thank you.  That got me looking in the right direction.

The backup restored the proper apache configuration for the ScriptAlias 
to remove the cgi-bin level from the URL, the base URL in the Mailman 
config file was not similarly adjusted so it kept directing to a 
directory that would not request the cookie.


On Jan 3, 2005, at 11:55 PM, Tokio Kikuchi wrote:

> Hi,
> Eric D Nielsen wrote:
>> I'm running the Debian Stable package of GNU Mailman.  Public 
>> archives work;
>> however private archives require endless authentication.  After the 
>> first
>> authentication I see the table showing all the months of messages, 
>> clicking on
>> any entry brings up the authentication page again.  This occurs with 
>> either the
>> master-site password or a regular list subscriber.
>> Cookies are being set properly.
> Possible scenarios:
> 1) You are redirected to another URL so that the browser doesn't send 
> the required cookie.
> Check your browsers URL window with wide open eyes if there is 
> something unusual.
> 2) There is an old and stale cookie remained in your browser and the 
> browser is sending it together with the new cookie. The server only 
> cheking the old one.
> Clear all the cookies related to your mailman site and retry.
> They are only suggestions. May work, may not work....
> -- 
> Tokio Kikuchi, tkikuchi@ is.kochi-u.ac.jp
> http://weather.is.kochi-u.ac.jp/

More information about the Mailman-Users mailing list