[Mailman-Users] Mailing list emails just disappear to nowhere

hannu at padasjoenlentokerho.fi hannu at padasjoenlentokerho.fi
Fri Jan 7 13:28:02 CET 2005

Hello all and sorry for the bother :)

A little background to my problem:

I had a main hard disk problem with my web/list server and though I 
had some backups I decided to install a fresh (and newer) 
installation of Linux. Now everything else is working fine except 
Mailman(and/or postfix).

It knows the lists I had built earlier fine, but sending mail to the 
lists doesn't work.

After trying to handle the problem myself, I got until so far:

In /var/log/mail I have a lines for the mail:

Jan  7 14:07:44 rbm postfix/cleanup[4820]: 2534CE585: message-
id=<20050107120744.2534CE585 at rbm.rbm-toolbox.net>
Jan  7 14:07:44 rbm postfix/smtpd[4802]: disconnect from 
Jan  7 14:07:44 rbm postfix/qmgr[4799]: 2534CE585: 
from=<hannu at padasjoenlentokerho.fi>, size=699, nrcpt=1 (queue active)
Jan  7 14:07:44 rbm postfix/local[4822]: 2534CE585: to=<hn-l at rbm.rbm-
toolbox.net>, orig_to=<hn-l at list.rbm-toolbox.net>, relay=local, 
delay=0, status=sent (delivered to command: 
/usr/lib/mailman/mail/mailman post hn-l)
Jan  7 14:07:44 rbm postfix/qmgr[4799]: 2534CE585: removed

So it would look quite all right ..... except that the mail doesn't 
appear anywhere. I am quite frustrated so far... any relief 

Otherwise postfix seems to work all right

My postconf-n looks like the follows:

alias_maps = hash:/etc/aliases
canonical_maps = hash:/etc/postfix/canonical
command_directory = /usr/sbin
config_directory = /etc/postfix
content_filter = 
daemon_directory = /usr/lib/postfix
debug_peer_level = 2
defer_transports = 
disable_dns_lookups = no
inet_interfaces = all
mail_owner = postfix
mail_spool_directory = /var/mail
mailbox_command = 
mailbox_size_limit = 0
mailbox_transport = 
mailq_path = /usr/bin/mailq
manpage_directory = /usr/share/man
masquerade_classes = envelope_sender, header_sender, header_recipient
masquerade_domains = 
masquerade_exceptions = root
message_size_limit = 10240000
mydestination = $myhostname, localhost.$mydomain, list.rbm-
toolbox.net, rbm.rbm-toolbox.net
myhostname = rbm.rbm-toolbox.net
mynetworks =,
newaliases_path = /usr/bin/newaliases
queue_directory = /var/spool/postfix
readme_directory = /usr/share/doc/packages/postfix/README_FILES
relayhost = 
relocated_maps = hash:/etc/postfix/relocated
sample_directory = /usr/share/doc/packages/postfix/samples
sender_canonical_maps = hash:/etc/postfix/sender_canonical
sendmail_path = /usr/sbin/sendmail
setgid_group = maildrop
smtp_sasl_auth_enable = no
smtp_use_tls = no
smtpd_client_restrictions = 
smtpd_helo_required = no
smtpd_helo_restrictions = 
smtpd_recipient_restrictions = 
smtpd_sasl_auth_enable = no
smtpd_sender_restrictions = hash:/etc/postfix/access
smtpd_use_tls = no
strict_rfc821_envelopes = no
transport_maps = hash:/etc/postfix/transport
unknown_local_recipient_reject_code = 450

and aliases 

mailman:	root
mailman-owner:	mailman
hn-l:	"|/usr/lib/mailman/mail/mailman post hn-l"
hn-l-admin:	"|/usr/lib/mailman/mail/mailman mailowner hn-l"
hn-l-request:	"|/usr/lib/mailman/mail/mailman mailcmd hn-l"
hn-l-owner:	hn-l-admin

Help me! ;)

best regards,

Hannu Niemi

No virus found in this outgoing message.
Checked by AVG Anti-Virus.
Version: 7.0.300 / Virus Database: 265.6.9 - Release Date: 6.1.2005

More information about the Mailman-Users mailing list