[Mailman-Users] "No such list mailman" after creating list - Possibly Solved?

Josh Simoneau jsimoneau at lmtcs.com
Tue Jul 26 17:18:33 CEST 2005

Alrighty, thanks everyone for the help, I solved (or at least
worked-around) the issue.

Apparently someone some time ago installed a mailman RPM onto this
server and just left it for dead without setting up postfix and all that
jazz. It installed everything into /var/mailman where I am installing
everything into /usr/local/mailman. 

For some reason my web server was looking to /var/mailman for data, even
though I cannot find anything in httpd.conf that points to /var/mailman.
So, while I was happily updating and tinkering with everything in
/usr/local/mailman Apache was looking to the wrong place and not finding
the lists or proper passwords.

So, my last challenge is to figure out why Apache is looking to
/var/mailman where I can't find anything in the config to tell it to
look there. Maybe its somewhere else. For a workaround I just renamed
the /var/mailman directory and created a symbolic link from /var/mailman
to /usr/local/mailman. It works, but I still want to know how to get
Apache to look to the right spot. 

I do have in httpd.conf:
ScriptAlias /mailman/       /usr/local/mailman/cgi-bin/
Alias   /pipermail/     /usr/local/mailman/archives/public/

That's not really the job of you folks here to troubleshoot Apache
issues, but if someone is feeling kind....

Thanks again,

-----Original Message-----
From: Mark Sapiro [mailto:msapiro at value.net] 
Sent: Tuesday, July 26, 2005 11:05 AM
To: Josh Simoneau; mailman-users at python.org
Subject: Re: [Mailman-Users] "No such list mailman" after creating list

Josh Simoneau wrote:

>The mailman list exists. I created it as defined in the installation 
>manual, it sent an email to the given email address, and it appears to 
>work properly on the email exchanging side of things. The web 
>administration side of things, however, does not work at all. It says 
>the list does not exist.
>If I create a new list with the command line, again it sends out the 
>appropriate email to the new list administrator. If I execute the 
>'list-lists' command (syntax could be off on that) it lists the mailman

>list, along with any others I have created. Any new list has the same 
>issue, web administration fails, only with "admin.py access for 
>non-existant list: whatevernewlistname".

This has to be a case of the web server not being able to access the
lists/ directory or its subordinates. If bin/check_perms finds no
problems, maybe its a SELinux issue.

Mark Sapiro <msapiro at value.net>       The highway is for gamblers,
San Francisco Bay Area, California    better use your sense - B. Dylan

More information about the Mailman-Users mailing list