[Mailman-Users] Bug on Version 2.1.5

Mark Sapiro msapiro at value.net
Tue Jun 14 18:52:11 CEST 2005

SER.RI-TIC - Jordi Tomàs Boqué wrote:
>today we found this Bug. Version of Mailman is 2.1.5. Maybe new version
>solve problem ?
>Jun 14 11:38:54 2005 admin(1293):
>admin(1293): [----- Mailman Version: 2.1.5 -----]
>admin(1293): [----- Traceback ------]
>admin(1293): Traceback (most recent call last):
>admin(1293):   File "/opt/URVmailman/scripts/driver", line 87, in run_main
>admin(1293):     main()
>admin(1293):   File "/opt/URVmailman/Mailman/Cgi/admindb.py", line 234,
>in main
>admin(1293):     num += show_helds_overview(mlist, form)
>admin(1293):   File "/opt/URVmailman/Mailman/Cgi/admindb.py", line 499,
>in show_helds_overview
>admin(1293):     KKKesender = _(esender)
>admin(1293):   File "/opt/URVmailman/Mailman/i18n.py", line 89, in _
>admin(1293):     return tns % dict
>admin(1293): TypeError: int argument required
>admin(1293): [----- Python Information -----]

This trace is not from Mailman 2.1.5 as distrubuted. It looks like at
least admindb.py has been patched (possibly by 'KKK'). The line

     KKKesender = _(esender)

is not in the distributed source.

It looks like the specific problem in this case may occur because the
sender address of the held message has a % character in it.

Mark Sapiro <msapiro at value.net>       The highway is for gamblers,
San Francisco Bay Area, California    better use your sense - B. Dylan

More information about the Mailman-Users mailing list