[Mailman-Users] Still installation woes

Rob Shepherd robshep at informatics.bangor.ac.uk
Sun Jun 19 22:54:31 CEST 2005

I can't believe this is giving me so much trouble.

mailman 2.1.6, solaris9 UltraSPARC 64bit

Some basic questions

I am running postfix as group "postfix" although mailman

*without* --with-mail-gid=postfix (imlies --with-mail-gid=mailman right?)

Mail comes through fine... is this OK?

I am running apache 2.0.52 as group  "apache2" and mailman

*with* --with-cgi-gid=apache2

Although if I want the web interface to work I must.....

su - mailman
cd /usr/local/mailman/cgi-bin
chmod g+s *

I can't decide whether these files should have been like this already??
check_perms found no errors!! but everything I've read suggest that these are 
wrapped by the code which does the bale out if the calling gid is not correct

from a fresh install I have no binary that is setgid mailman
only directories

Is the installation broken? what other files need to be setgid?

/usr/local/mailman/mail/mailman is *not* setgid but postfix can pipe to that OK,

Also, should I end up with "any" files being owned by apache2?  after using the 
web interface to add a list I found that aliases, aliases.db and 
virtual-mailman.db were still the original ownership but virtual-mailman had 
been claimed ownership by apache2.... is this right,

If anyone can provide a....

`ls -laR`

of /usr/local/mailman from as clean an installation as possible

to robshep atttt informatics d0t bangor.ac.uk , it would be most appreciated.


  *	Rob Shepherd,
  *	University Of Wales, Bangor,
  *	School of Informatics,
  *	Dean Street,
  *	Bangor,
  *	Gwynedd, UK     /\  /\
  *	LL57 1UT       /  \/  \ /\
  *	--------------/---/    \--\----
  *	robshep at informatics.bangor.ac.uk
  *	+44 (0) 1248 38 27

More information about the Mailman-Users mailing list