[Mailman-Users] Help getting SuSE 9.3+Mailman 2.1.5+Apache2 working

Poster Poster at aurora.cotse.net
Tue Jun 28 10:53:57 CEST 2005

Michael Regoli said:
> Hello! I'm trying to get mailman and Apache2 working nicely from the
> stock SuSE distro. (YOU, Yast Online Update is current on the machine,
> so if there's new stuff for either mailman or Apache2, I've got it.
> mailman is version [2.1.5] and Apache2 is version [2.0.53].)

I had a similar problem -- I think. I have Suse 9.3, stock Mailman and
stock Apache2, all updated with YOU. In my case, it was first the
inability for Mailman to run as the right GID, then it was the
inability to read the wrapper config files (which incidentally, don't
exist). Scouring the internet led me to clues that the error really
meant that the GID was still wrong. Nothing I did worked. I changed
the UID GID files that Mailman uses. I tweaked the mailman.conf files
in /etc/apache2. I inspected mail.err logs in /var/log. I changed
perms, owner, group, and access bits on everything that seemed
related. Still nothing.

Finally, out of sheer desperation, I reinstalled the stock Suse
Mailman RPM running as the mailman user. Then I checked (and fixed)
permissions issues using the scripts in /usr/lib/mailman/bin. With the
mailman cgi files moved to /cgi-bin/mailman and aliased in apache's
default-server.conf file (and given their own separate <Directory>
section with CGI script running turned on), everything worked!

I'm convinced that a reinstall is necessary to fix some permissions
SOMEWHERE. I spent way too much time trying to debug it, but with
mailman's lame, unhelpful error messages, there's just not much I
could do.

I don't use virtual servers yet, but I expect I will soon. And BTW,
the error message you're currently seeing is an Apache error message.


+        www.intaligo.com/mt         +
+  Professional Editing/Web Design   +
+        www.intaligo.com/mt         +

More information about the Mailman-Users mailing list