[Mailman-Users] Permission problems cause postfix postalias error

Graham Leggett minfrin at sharp.fm
Thu Mar 3 09:32:32 CET 2005

Todd said:

>> I have run the bin/check_perm script, but to no avail. Does anybody know
>> what should be done to make this work? I tried adding the postfix user
>> to the mailman group, but it didn't work.
> See: http://www.python.org/cgi-bin/faqw-mm.py?req=show&file=faq06.009.htp

This FAQ entry repeats the docs - I tried setting the permissions to
"mailman:mailman" but this did not work either.

There seem to be a few problems at work:

- The check_perms script is setting the ownership of the files to "root",
when the docs say they should be "mailman".

- Even when set to mailman:mailman, postalias still throws an error.

Something strange that I have found is that if you delete the *.db files,
postalias seems to recreate them, but these *.db files do not map the
permissions of the original alias files (the virtual-mailman.db file is
owned by "apache" for example).

Can anybody send me an "ls -al" from a working mailman setup, so that I
can see what the permissions should look like?


More information about the Mailman-Users mailing list