[Mailman-Users] Security update for 2.1.5

Mark Sapiro msapiro at value.net
Tue Mar 22 22:17:27 CET 2005

Terry Allen wrote:

>I should have outlined that I had already tried 
>running patch on that .txt file - here's the problem I am getting:
>[server:mailman/mailman/cgi] root# patch < CAN-2005-0202.txt
>patching file private.py
>Reversed (or previously applied) patch detected!  Assume -R? [n] n
>Apply anyway? [n] y
>Hunk #1 FAILED at 1.
>1 out of 2 hunks FAILED -- saving rejects to file private.py.rej
>[server:mailman/mailman/cgi] root#
>	The output into the .rej file has only the comments at the 
>start of private.py - I ran the patch 3 times but on the second time 
>I answered Y on the reverse apply question, then the 3rd time, it ran 
>without error. does this indicate to you that I have already applied 
>the patch successfully?

It looks like the first time, patch failed to apply the first hunk (the
Copyright notice) because it had already been applied. The second
time, answering Y to the 'reverse' question effectively removed the
patch, and the third try successfully reapplied the patch.

Mark Sapiro <msapiro at value.net>       The highway is for gamblers,
San Francisco Bay Area, California    better use your sense - B. Dylan

More information about the Mailman-Users mailing list