[Mailman-Users] unknown mailer problems

Ashley M. Kirchner ashley at pcraft.com
Thu Mar 24 06:12:16 CET 2005

Mark Sapiro wrote:

>It's hard to know what the problem might be because you seem to be
>presenting a moving target and not telling us much about what you're
>doing. Your initial post was about suEXEC and removing the setgid bit
>from the various wrappers in the cgi-bin/ directory.
    Yes it was, and after removing the set-gid bits from everything 
within the /cgi-bin/, I kept on trucking because it seemed to run just 
fine.  I say "seemed" because I haven't done a whole lot of testing just 
yet.  When I was ready to do that, I ran into the unknown mailer 
problem...  Which by the way has now been solved as well.  Keep reading 

>First of all, the scripts/post script is not normally found
>in the lists/ directory.
    This is correct, however I run mailman across several domains, on 
the same server, and its built-in virtual domain capabilities simply 
don't allow me to do what I want to do (or what my clients want.)  So, I 
install mailman under one user, but in separate folders (for separate 
domains) /lists/ being one of them (this by the way was brought up 
several times in the past.)  So yes, your assumption is correct, I do 
configure mailman with --prefix=/home/mailman/<domain>/

>So, are you trying to remove setgid from everything and somehow give
>permissions to the mail-gid and the cgi-gid? I don't really know about
>running Mailman under suEXEC.....
    Neither do I, however with our recent web server upgrades and 
batting down the hatches, I'm forces to find a way to install Mailman 
under suexec.  So this was my project of the day.

>I think what this really means is it isn't possible to set Mailman up
>properly to run with suEXEC.
    Maybe so, however I'm still testing it out.  Yes, I have removed the 
set-gid bit from anything within the /cgi-bin/ folder since that's what 
suexec requires.  As for the other error (unknown mailer error), python 
won't read/execute programs in a folder that's g-x which /home/mailman/ 
was.  Once that restriction was removed, it happily worked.

    Now I need to continue testing, sending myself mail, subscribing, 
etc., etc.  So far, it's working.

H | I haven't lost my mind; it's backed up on tape somewhere.
  Ashley M. Kirchner <mailto:ashley at pcraft.com>   .   303.442.6410 x130
  IT Director / SysAdmin / WebSmith             .     800.441.3873 x130
  Photo Craft Imaging                       .     3550 Arapahoe Ave. #6
  http://www.pcraft.com ..... .  .    .       Boulder, CO 80303, U.S.A. 

More information about the Mailman-Users mailing list