[Mailman-Users] Outbound smtp email problems: (110, 'Connection timed out')

Matt England mengland at mengland.net
Mon May 16 18:51:30 CEST 2005

At 5/16/2005 10:27 AM, Mark Sapiro wrote:
>Jim Tittsler wrote:
> >
> >Mailman tries to connect to your mail host (DEFAULT_EMAIL_HOST
> >in the simplest case, but it is a function of the
> >add_virtualhost() statements in your mm_cfg.py).  This is not
> >specified as localhost (or so this is not a fair
> >test.
>Are you sure Jim? This is the code in SMTPDirect.py
>     def __connect(self):
>         self.__conn = smtplib.SMTP()
>         self.__conn.connect(mm_cfg.SMTPHOST, mm_cfg.SMTPPORT)
>         self.__numsessions = mm_cfg.SMTP_MAX_SESSIONS_PER_CONNECTION

It doesn't much matter from what I can tell.  I ran the following test, 
where lists.biz2tek.com is both the email and URL host.

root at biz2tek 11:46am [/etc] 14> telnet lists.biz2tek.com 25
Connected to lists.biz2tek.com.
Escape character is '^]'.
220 biz2tek.com ESMTP
250 biz2tek.com
mail from:<mailman at lists.biz2tek.com>
250 ok
rcpt to:<blah at mengland.net>
250 ok
354 go ahead
Subject: test
just a test.
250 ok 1116262038 qp 32097
221 biz2tek.com
Connection closed by foreign host.
root at biz2tek 11:47am [/etc] 15>

The above failed previously, but I updated /etc/tcp.smtp to relay from 
lists.biz2tek.com, and now it works...but SMTP based outbound mail still 
does not work.

I still can get the sendmail-based mechanism (with qmail impersonating 
sendmail) to work, but the SMTP-based mechanism does not work.

And yes, this does appear to be qmail problem (I'll followup the other 
notes).  And yes, qmail does have a sendmail "drop in" as far as I can tell 
(I've been using it for months now).

I realize this is a Mailman group, so I may stop with this thread (other 
then following up a couple other points) given that it appears to be a 
qmail issue...but any input is appreciated.  :)


More information about the Mailman-Users mailing list