[Mailman-Users] the "shunt" mail queue

JOSEPH DAMICO damico.1 at osu.edu
Thu Oct 27 19:39:01 CEST 2005

Many thanks, Mark.

I had run check_perms earlier (when I installed), but must have messed up a few permissions since then.  This fixed eveything.

Excellent suggestion!


----- Original Message -----
From: Mark Sapiro <msapiro at value.net>
Date: Thursday, October 27, 2005 11:52 am
Subject: Re: [Mailman-Users] the "shunt" mail queue

> >
> >I sent a message to a mailman list on my server.  The message was 
> not delivered.   At first, I got a mesage indicating that sendmail 
> was not running with group=mailman.  So I stopped and started 
> sendmail with group=mailman.  This allowed the mail to get as far 
> as the "in" queue but could go no farther.  Permission errors 
> during processing clued me into the idea of stopping and re-
> starting sendmail with user=mailman and group=mailman.  Now, I see 
> no error messages, but the notes I post to the list are ending up 
> in the "shunt" queue. 
> >
> Actually, running from the group that the wrapper expects should be
> sufficient. The fact that it wasn't indicates you still have
> permission problems in your Mailman hierarchy. Run
> bin/check_perms
> as root. If there are errors, run
> bin/check_perms -f
> until they're gone.
> -- 
> Mark Sapiro <msapiro at value.net>       The highway is for gamblers,
> San Francisco Bay Area, California    better use your sense - B. Dylan

More information about the Mailman-Users mailing list