[Mailman-Users] Permissions problem/symlinks on a RAQ4

mailman at yingtong.co.uk mailman at yingtong.co.uk
Sun Sep 25 22:31:37 CEST 2005

Hi,  I have installed a partially working version of Mailman 2.1.6 with
Python 2.4.1 on a RAQ4

THe actual lists are working but the problem is with the web interface
reporting a permission problem, and the httpd error log reporting
"Symbolic link not allowed"

THe background to it is that I've run usr2home (which does does what it
says, and moves the files to create more space and symlinks the usr
folder.)  RAQs have limited space in /usr.

I ran the ./configure with mailman mail and httpd gids as normal and it
all installs,  set up lists via command line etc, but try as I might the
web interface refuses to display

In httpd.conf


ScriptAlias /mailman/ "/usr/local/mailman/cgi-bin/"
Options +ExecCGI +FollowSymLinks
AddHandler cgi-wrapper .cgi
AddHandler cgi-wrapper .pl
<Directory "/usr/local/mailman/cgi-bin">
Options +ExecCGI +FollowSymLinks


(Tried with and without quotes btw)

Nothing gives.

I tried installing to /home/mailman and there I got the gui up but for
the life of me couldn't get the mail to work!  Also the gui displayed
but then no values submitted entered the database and retained????

Users and groups are AFAICT set correctly, and check_perms is fine.
(THough I don't pretned to understand the finer details of how
permissions work)

Please, can anyone give a pointer, (and in return I'll do a FAQ for
installing on a RAQ!)


More information about the Mailman-Users mailing list