[Mailman-Users] Bug in Mailman 2.1.4

Bob Bergey bob at bergey.net
Tue Jun 13 18:51:33 CEST 2006

I have more than a dozen lists running in Mailman 2.1.4 on my Xserve, 
all running fine, except that now on just one list I'm unable to 
access the admin pages. The list is still sending messages okay, 
individual subscribers can access their subscription options, 
archives are fine, etc. -- but I get an error after trying to sign in 
with my admin password. It's processing the admin password, because 
if I intentionally type the wrong one, I get the authorization failed 
message. But if I type the correct password, I get a "Bug in Mailman 
2.1.4" message -- starts out like this:

------------begin copy------------

Bug in Mailman version 2.1.4

We're sorry, we hit a bug!
If you would like to help us identify the problem, please email a 
copy of this page to the webmaster for this site with a description 
of what happened. Thanks!

Traceback (most recent call last):
   File "/usr/share/mailman/scripts/driver", line 87, in run_main
   File "/usr/share/mailman/Mailman/Cgi/admin.py", line 200, in main
   File "/usr/share/mailman/Mailman/MailList.py", line 526, in Save
   File "/usr/share/mailman/Mailman/MailList.py", line 498, in __save
OSError: [Errno 22] Invalid argument: 

------------end copy------------

Any suggestions on working around this? Admin pages for all other 
lists on the same server are working fine!


Bob Bergey -- 215-527-1048 -- Perkasie, PA     <mailto:bob at bergey.net>
Internet Services for the Printing Industry <http://www.printweb.org/>
Web Hosting & E-Mail Services:  BERGEY.NET    <http://www.bergey.net/>

More information about the Mailman-Users mailing list