[Mailman-Users] new install/email confirmation not working

Christopher Adams adamsca at gmail.com
Fri Jun 23 21:57:45 CEST 2006

On 6/23/06, Mark Sapiro <msapiro at value.net> wrote:
> Christopher Adams wrote:
> >
> >On the new server, I have installed Mailman, run 'configure' and 'make
> >install'. I have restarted Postfix and Mailman.
> >
> >I have set up a new list and received email confirmation. I can add
> myself
> >as a subscriber via the web interface and get an email confirmation.
> >
> >If I try to subscribe via email, nothing happens. The log files don't
> show
> >any email activity related to that transaction.
> >
> >I have tried running configure with mail gid= postdrop, since that is
> what
> >Postfix was compiled to run under. That didn't work, so I have tried mail
> >gid = mailman and mail gid = postfix. The results are always the same.
> It doesn't seem the mail is getting even that far. Do you have MTA =
> 'Postfix' in mm_cfg.py? Have you added path/to/data/aliases to
> Postfix's alias_maps? See
> <http://www.list.org/mailman-install/node13.html>.

MTA='Postfix' is in the mm_cfg.py file. I am not integrating Mailman and
Postfix so that aliases are generated. I am utilizing /etc/aliases for the
aliases file.

Note that Postfix will deliver to Mailman with owner:group of the
> aliases.db file it finds the aliases in. This is normally group
> 'mailman' for data/aliases*, so for Postfix, you normally want
> --with-mail-gid=mailman which is included in the default for configure.
> What is in the Postfix logs for mail to Mailman?

There is nothing in the Postfix logs referring to Mailman, except if I do
the subscribe from the Admin interface.

Christopher Adams
adamsca at gmail.com

More information about the Mailman-Users mailing list