[Mailman-Users] problem upgrading from 2.0.11 to 2.1.8 on Solaris 9with Python 2.4

Kralizec Craig cd at lios.apana.org.au
Tue Jun 27 05:01:06 CEST 2006

On Mon, 26 Jun 2006, Mark Sapiro wrote:

> update is trying to convert a pending subscription request from  2.0.11
> format to the current pending.pck per list format and at the point of
> the error, data[0] is supposed to be a UserDesc instance and it is a
> string.
> If you are willing to abandon any unconfirmed subscribe, unsubscribe,
> address change or delivery re-enable requests or confirmation of held
> messages (I think they'll still be in the admindb web interface), you
> can just rename or move aside the data/pending.db file and rerun
> 'bin/update' which is the only part of the install that didn't
> complete.

The data/pending_subscriptions.db file is only 96 bytes. I've renamed it 
to something different and the install has worked this time. Will do the 
things that the UPGRADING file says to look at and make sure the lists are 
still working.


More information about the Mailman-Users mailing list