[Mailman-Users] strange warning on mm2.1.5

Mark Sapiro msapiro at value.net
Wed May 31 02:07:12 CEST 2006

Sythos wrote:
>/var/lib/mailman/Mailman/Handlers/Scrubber.py:175: DeprecationWarning:
>get_type() deprecated; use get_content_type() ctype = part.get_type
>Uhm... it is only a warning... all work, anyone else have this message from
>list cron?

Something is wrong with your Mailman installation. Mailman 2.1.5
contains version 2.5.5 of the Python email library and it should be
installed in $prefix/pythonlib/email and the $prefix/pythonlib/
directory should be inserted at the beginning of sys.path by
cron/paths.py which is imported by all the cron scripts.

Somehow, something is missing in the above and you are getting the
Python 2.4 email library imported in your cron scripts which is
issuing the deprecation warning.

Mark Sapiro <msapiro at value.net>       The highway is for gamblers,
San Francisco Bay Area, California    better use your sense - B. Dylan

More information about the Mailman-Users mailing list