[Mailman-Users] Mailman Scrubbing archived attachments

Mark Sapiro msapiro at value.net
Fri Oct 13 18:00:51 CEST 2006

Mardi Wetmore wrote:

>Ok, I think I get it.  But, here's what we get at the bottom of the e-mail:
>-------------- next part --------------
>A non-text attachment was scrubbed...
>Name: 04_540pins.pdf
>Type: application/pdf
>Size: 69000 bytes
>Desc: not available
>Url :
>The URL is not a URL that works.  It does not come up as a clickable URL and
>if you paste it into a browser and it goes nowhere.

As I tried to indicate in my reply at
the Mailman installation itself is broken or misconfigured.

The URL should be
and it should be a clickable link in the archive. This URL does work
(I tried it).

For an example of how this is supposed to look in the archive, see

I also visited <http://cohousing-corvallis.com/mailman/listinfo/> and I
see this is a cPanel installation. I don't know if the problem is the
cPanel Mailman or a misconfiguration, but it any case, it will
probably have to be addressed by cPanel or the administration of the
hosting server. See

Whoever is checking into this should first check the Defaults.py and
mm_cfg.py setting for PUBLIC_ARCHIVE_URL. The setting in Defaults.py
is (should be)

PUBLIC_ARCHIVE_URL = 'http://%(hostname)s/pipermail/%(listname)s'

it should not be overridden in mm_cfg.py. It appears in your case it
may be

PUBLIC_ARCHIVE_URL = '/pipermail/%(listname)s'

which is wrong.

Mark Sapiro <msapiro at value.net>       The highway is for gamblers,
San Francisco Bay Area, California    better use your sense - B. Dylan

More information about the Mailman-Users mailing list