[Mailman-Users] Help newbie with a common error (smrsh)?

Tony Croes tcroes at ctrcc.com
Sat Oct 21 20:08:55 CEST 2006

I have just installed mailman on a RHEL4 system from the RedHat network via
RPM. I can reach the list and admin tools via the web (i.e. cgi working). I
can create lists, add new users and submit posts. However, these posts only
show up in the web archives. I'm not getting them as forwarded email

When I look at the archives, I see repeated posts from Cron <mailman at server>
with the following error:

    "/bin/sh: mailman: command not found"

I've tried to follow the faq (3.14 Troubleshooting: No mail going out to
list members), but so far no luck. Here is some additional information:

mailman exists and is executable (tried as root):
[root at server mail]# /usr/lib/mailman/mail/mailman
Usage: /usr/lib/mailman/mail/mailman program [args...]
[root at server mail]# file mailman
mailman: setgid ELF 32-bit LSB executable, Intel 80386, version 1
(SYSV), for GNU/Linux 2.2.5, dynamically linked (uses shared libs), not
[root at server mail]# ll mailman
-rwxrwsr-x 1 root mailman 19154 Aug 23 07:22 mailman

"smrsh" symlink:
[root at server mail]# ls /etc/smrsh/
[root at server mail]# file /etc/smrsh/mailman
/etc/smrsh/mailman: symbolic link to `/usr/lib/mailman/mail/mailman'

I have these aliases. I commented out the first two which must have been put
there by the RPM install. I have not tried commenting out the duplicates
lower in the list and leaving the originals in:

# mailman aliases
# mailman: postmaster
# mailman-owner: mailman

# mailman mailing list
mailman: "| /usr/lib/mailman/mail/mailman post mailman"
mailman-admin: "| /usr/lib/mailman/mail/mailman admin mailman"
mailman-bounces: "| /usr/lib/mailman/mail/mailman bounces mailman"
mailman-confirm: "| /usr/lib/mailman/mail/mailman confirm mailman"
mailman-join: "| /usr/lib/mailman/mail/mailman join mailman"
mailman-leave: "| /usr/lib/mailman/mail/mailman leave mailman"
mailman-owner: "| /usr/lib/mailman/mail/mailman owner mailman"
mailman-request: "| /usr/lib/mailman/mail/mailman request mailman"
mailman-subscribe: "| /usr/lib/mailman/mail/mailman subscribe mailman"
mailman-unsubscribe: "| /usr/lib/mailman/mail/mailman unsubscribe mailman"

This is the kind of output I get when I tail maillog:

Oct 21 12:27:14 server sendmail[19396]: k9LHRDWj019396:
from=<tony.croes at sbcglob al.net>, size=1676, class=0, nrcpts=1,
msgid=<200610211727.k9LHRDWj019396 at server .ctrcc.com>, proto=SMTP,
daemon=MTA, relay=smtp102.sbc.mail.mud.yahoo.com [68.14 2.198.201]
Oct 21 12:27:15 server MailScanner[11624]: New Batch: Scanning 1
messages, 2280 bytes
Oct 21 12:27:21 server MailScanner[11624]: Virus and Content Scanning:
Oct 21 12:27:23 server MailScanner[11624]: Uninfected: Delivered 1
Oct 21 12:27:23 server MailScanner[11624]: Batch (1 message) processed
in 7.97 s econds
Oct 21 12:27:24 server sendmail[19580]: k9LHRDWj019396:
to="| /usr/lib/mailman/m ail/mailman post mailman",
ctladdr=<mailman at server.ctrcc.com> (8/0), delay=00:00 :10,
xdelay=00:00:00, mailer=prog, pri=121676, dsn=2.0.0, stat=Sent

Thanks for your help.

More information about the Mailman-Users mailing list