[Mailman-Users] htdig authorization problem

Mark Sapiro msapiro at value.net
Fri Jan 19 18:31:35 CET 2007

Hank van Cleef wrote:
>I rebuilt the archives from the list mbox file a couple of weeks ago,
>and htdig would search on it, deliver pages, and they could be viewed.
>This week (several days later), to view a post requires entering 
>a password before viewing.

Did you change the archive from public to private? Do you have to enter
the password each time (not normal) or only once (normal for a private

>Trying to pull up a second page gets an
>error message.

What error message? If it's the 'we hit a bug' message, what's in
Mailman's error log?

>This affects using the list admin password as well as
>user passwords.  To view any hit, a user account name or the admin
>pasword (not both) has to be entered in a validation screen.  

Normal for a private archive, but should only be required the first

>The mailman error log reports
>htsearch for list: mercedes, cause: auth, detail: -10-

Looking briefly at the htdig patch, I think this comes from mmsearch.py
when private archive authorization fails.

>Browsers have cookies enabled (mine certainly does).  Where do I look?
>Permissions on the private directory were 2770; I reset them to 2774.

They shouldn't be 2774. They might need to be 2771 for public archive
access to work. Otherwise 2770 should be fine. At this point the
process should be running as the 'mailman' group because of the SETGID
on the wrapper.

>All of the files in private/listname are owner/group both mailman,
>permissions on files are 666, on directories, 2775.
>Where do I go from here?  

I'm not sure anything is wrong, but if you are being required to
authorize more than once per session per list, then there is a
problem. What about normal archive access without searching? does that

Mark Sapiro <msapiro at value.net>       The highway is for gamblers,
San Francisco Bay Area, California    better use your sense - B. Dylan

More information about the Mailman-Users mailing list