[Mailman-Users] Mail not going to all members

Mark Sapiro msapiro at value.net
Fri Mar 23 19:22:25 CET 2007

Grant Carmichael wrote:
>The following command printed everyone in the list:
>/usr/local/mailman/bin/list_members --regular --nomail=enabled info
>This command printed nothing:
>/usr/local/mailman/bin/list_members --regular --nomail info
>Any other ideas?

Please keep conversations on the list unless there are specific privacy

I assumed from your report of the maillog that mailman is sending to
only one address. Please confirm this by looking in Mailman's smtp log
for the "<message id> smtp for n recips completed in n.nnn seconds"
entry and verifying that n=1. Also look in Mailman's smtp-failure log
to confirm there are no smtp time rejects by Postfix.

Assuming all this is OK and Mailman is sending to just one recipient,
other reasons why a delivery enabled regular member won't be sent a
copy include:

The member has nodups set and is addressed explicitly in To:, Cc:,
Resent-To: or Resent-Cc: of the post.

The post is From: the member and the member has not_metoo set.

The member is subscribed to Topics and the post doesn't match. Note
that it is possible for a member to have a residual topic selection
even if the list currently has no topics defined and this can affect
delivery if the member has not opted to receive posts not matching any

Mark Sapiro <msapiro at value.net>       The highway is for gamblers,
San Francisco Bay Area, California    better use your sense - B. Dylan

More information about the Mailman-Users mailing list