[Mailman-Users] genaliases problem

Tomas Macek macek at fortech.cz
Fri Mar 30 09:04:20 CEST 2007

Hi, I'm new to Mailman and I have problem with genaliases. I'm using Mailman 2.1.5 on RHEL 4 with Postfix.

I read the /usr/share/doc/mailman- and tried to setup postfix like mentioned in 'VIRTUAL DOMAINS' section.

Postfix's /etc/postfix/main.cf:
virtual_alias_maps =    pgsql:/etc/postfix/pgsql/alias_domains_maps.cf \
                         pgsql:/etc/postfix/pgsql/alias_mailbox_maps.cf \

recipient_delimiter = -

Mailman's /usr/lib/mailman/Mailman/mm_cfg.py:
VERP_FORMAT = '%(bounces)s+%(mailbox)s=%(host)s'
VERP_REGEXP = r'^(?P<bounces>[^+]+?)\-(?P<mailbox>[^=]+)=(?P<host>[^@]+)@.*$'
VERP_PROBE_REGEXP = r'^(?P<bounces>[^+]+?)\-(?P<token>[^@]+)@.*$'
VERP_CONFIRM_FORMAT = '%(addr)s+%(cookie)s'
VERP_CONFIRM_REGEXP = r'^(?P<addr>[^+]+?)\-(?P<cookie>[^@]+)@.*$'

MTA = 'Postfix'

I also tried to create a new list by command 'bin/newlist list at our_domain.com' and wrote what I've been asked. Then I created 'data' directory, with chmod and chown, make bin/genaliases and /etc/init.d/mailman restart. After typing genaliases command I expected mailman to create data/virtual-mailman and data/virtual-mailman.db files, but absolutely nothing happened.

What I'm doing wrong? I found nothing about it in README* documents nor in FAQ.

Thank you for help, Tomas

More information about the Mailman-Users mailing list