[Mailman-Users] Low level smtp error: Server not connected

Barry Warsaw barry at python.org
Tue May 29 16:25:22 CEST 2007

Hash: SHA1

On May 29, 2007, at 6:21 AM, Leonard Jacobs wrote:

> Thanks for your suggestion to read the FAQ and the associated list
> postings. I actually found those same postings and tried every
> suggestion in them that was relevant. Unfortunately nothing worked to
> resolve this annoying problem. There may be a setting that is  
> incorrect
> and there may be something posted that explains this problem and
> provides a solution but so far I have not located anything that  
> fixes it
> for me.
> It is strange that a pretty vanilla installation, CentOS and Postfix
> with the latest Mailman version of 2.1.9 is so hard to configure and
> use. And this after using it on a CentOS 3 box but with frequent  
> delays
> in sending and unusal errors. So moving the list was necessary but  
> made
> the list totally unusable. I have heard from a few others with similar
> problems and no solution, so I know I am not the only user with these
> issues.
> Any further suggestions would be appreciated.

I don't have any idea what's going on, but here are some mostly  
useless comments.

I'm personally still on Postfix 2.3.6, and you mentioned that you're  
on Postfix 2.4.1.  I wonder if there isn't some new feature, anti- 
spam defense, or other setting that is tripping up Mailman.  It's  
also possible that Postfix 2.4.1 has some bug that's causing it to  
reset the connection.  I don't have time to slog through the Postfix  
change logs, but I suggest you take a look to see if there's anything  

You might also try the Postfix 2.4.2 release candidate, and/or  
grabbing Postfix 2.3.9 to see if that improves things.  IME, Postfix  
is pretty easy to build and install from source.

If I were debugging this, my next step would probably be to write  
some sample Python applications that stress tested SMTP connections  
from a Python program.  Mailman uses Python's standard smtplib  
module, so that's where I'd start.  See if you can reproduce the  
problem outside of Mailman.

I agree with previous posters that this is almost certainly a problem  
with your Postfix installation.  Mailman + Postfix has been a long- 
term very stable combination, although as I said, it's possible  
there's something in Postfix 2.4 that's tripping us up now.

Does anybody else use Postfix 2.4?

- -Barry

Version: GnuPG v1.4.7 (Darwin)


More information about the Mailman-Users mailing list