[Mailman-Users] Address change failure

G. Armour Van Horn vanhorn at whidbey.com
Fri Nov 2 19:45:33 CET 2007


I'm having problem with administratively changing addresses. When I get 
a request to change addresses on this list I normally just go ahead and 
change it figuring that it's easier than explaining the process to those 
who didn't just go and change it themselves to start with. Several times 
this year I've had Mailman report success but continue to show the 
original address. Unfortunately I haven't kept a log of this to come up 
with any patterns.

In the most recent case, the username did not change while the domain 
did. I opened a ticket on the problem and the system admin suggested it 
was a Mailman bug when only the domain changed. (I am moderator on this 
list, I haven't had the same problem on my own server but also haven't 
had a need to make many changes on the small lists there.) The list in 
question is on Mailman 2.1.9, and I've been very impressed with the 
skill of the administrator so I don't think they've messed anything up - 
they run quite a few large high-volume lists.

Is this a known bug? Is there anything we should be looking at? As of 
now I am logging changes and may see a pattern over time, but it could 
be a long time depending on activity.


Sign up now for Quotes of the Day, a handful of quotations
on a theme delivered every morning.
Enlightenment! Daily, for free! 
mailto:twisted at whidbey.com?subject=Subscribe_QOTD

For photography, web design, hosting, and maintenance, 
visit Van's home page: http://www.domainvanhorn.com/van/

More information about the Mailman-Users mailing list