[Mailman-Users] Mailman in chrooted OpenBSD

Mark Sapiro msapiro at value.net
Sat Sep 8 03:24:41 CEST 2007

Patrick Valenciawrote:
>I configured it as such:
>./configure --prefix=/var/www/mailman --with-mail-gid=67 --with-cgi-gid=67
>--with-username=_mailman --with-groupname=_mailman
>(using the _mailman user & group from the port install)  and I still get the
>same error:
>Failure to find group name for GID 67. Mailman
>expected the CGI wrapper to be executed as group
>"www", but the system's web server executed the
>wrapper as GID 67 for which the name could not be
>found.  Try adding GID 67 to your system as "www",
>or tweak your web server to run the wrapper as group
>I was pretty sure that this would force mailman to look for '67' as the
>group, but it seems to still be looking for 'www'.

I too thought that would be the case, but closer examination of
configure says that when you give it --with-cgi-gid=<numeric>, it
looks up the group name that corresponds to the numeric gid and uses
the name.

Also, the specific "Failure to find group name for GID 67" message from
the wrapper comes from the inability to find a group name for the
numeric gid under which it was invoked, and the expected group "www"
is the compiled in group name that came from looking up 67 at
configure time.

The bottom line is I think you have two options.

Figure out how to make the web server (cgi-gid) and the MTA (mail-gid)
invoke the respective wrappers with some gid that can be resolved to a
name inside the chroot jail, and configure those as the expected

or modify the code in src/common.c to either bypass the group tests or
change them to something that will work.

You might also look at
and the containing thread and the results of

Mark Sapiro <msapiro at value.net>       The highway is for gamblers,
San Francisco Bay Area, California    better use your sense - B. Dylan

More information about the Mailman-Users mailing list