[Mailman-Users] No outgoing mails with Postfix when sending mail tolist

Mark Sapiro mark at msapiro.net
Tue Aug 19 17:20:41 CEST 2008

Matthias Laug wrote:
>I'm stuck with a problem. I've installed mailman and postfix via apt (debian
>If I register a user or a bounce message is sent to the list owner, the
>emails go through and are received by the recipient. But if any user sends
>an email to the list, it will be archieved but not send to all llist
>There seems to be something wrong with the aliases, because if I change
>postfix config (main.cf) from
>alias_maps = hash:/var/lib/mailman/data/aliases
>alias_database = hash:/var/lib/mailman/data/aliases.db
>alias_maps = hash:/etc/aliases
>alias_database = hash:/etc/aliases
>email are send to list members, but along with an error message 550, that
>the adress is not available.

Your aliases are fine. In the second case, Postfix does not know hoy to
teliver to the list so it returns the mail to you only with the 550

When you have Postfix correctly configured as in the first case, the
aliases work. If they didn't, the message wouldn't be archived. See
<http://wiki.list.org/x/2IA9> for the probable reason why you don't
receive your own posts.

If you have really verified that you don't receive posts sent by other
list members and/or other list members don't receive posts sent by
you, see <http://wiki.list.org/x/A4E9>.

Mark Sapiro <mark at msapiro.net>        The highway is for gamblers,
San Francisco Bay Area, California    better use your sense - B. Dylan

More information about the Mailman-Users mailing list