[Mailman-Users] Mail getting stuck in queue

Mark Sapiro mark at msapiro.net
Fri Jun 6 21:19:22 CEST 2008

Laura Conrad wrote:
>Intermittently, but increasingly frequently, the mailman I'm running
>is getting into a state where messages are received and archived, but
>not logged in the "posts" file or sent out by smtp.  
>This situation usually resolves itself after I kick it enough.  Maybe
>it would resolve itself if I didn't kick it at all.  I would like to
>understand what's happening, so I can either stop it happening, or
>kick it more efficiently.
>This is on a mailman 2.1.10 installed from source on ubuntu 7.10.  The
>machine is running postfix.  The mail log indicates that postfix has
>passed the stuck mails to mailman:

Which you already knew because they are archived.

>I've checked all the things in
>At one point, there was a second (old) OutgoingRunner process after I
>had stopped and started mailmanctl several times, which I had to kill
>by hand, but usually this isn't the case.  
>Here's my kick_mailman.sh script; I also reboot the system when I've
>tried this and it hasn't worked.  When the queue gets unclogged, it
>isn't ever immediately after any of these things, including the
>There are errors in the error log:
>Jun 05 13:38:41 2008 (7364) Failed to unlink/preserve backup file: /home/mailman/qfiles/out/1212668722.1033101+99ec79fd321b54afb77e0ef5c8b0f5d2625e6aea.bak
>Jun 06 13:07:58 2008 (12803) Failed to unlink/preserve backup file: /home/mailman/qfiles/out/1212763581.350471+f1f22720a6342cd0ce99e4d29a21251f7440d973.bak

I think these are a result of the 'kicking' process, but it's hard to
say since the script wasn't here.

>and in the smtp-failure log:
>Jun 06 13:11:29 2008 (16109) Low level smtp error: (4, 'Interrupted system call'), msgid: <53c661160806060746y3372989ctf142728bc035ff4d at mail.gmail.com>
>Jun 06 13:56:33 2008 (5154) SMTP session failure: 250, ok, msgid: <53c661160806060746y3372989ctf142728bc035ff4d at mail.gmail.com>
>Jun 06 13:56:33 2008 (5154) delivery to <redacted>@gmail.com failed with code -1: (4, 'Interrupted system call')
>What is happening between when mailman gets my mail and when it
>finally agrees to disgorge it via smtp?  It is in the stuck state
>right at the moment, if someone can walk me through more debugging.

In which queue (subdirectory of qfiles/) are the messages? Almost
certainly in 'out'.

The smtp-failure entries seem to say that there is some problem between
OutgoingRunner and the MTA.

In the stuck state, OutgoingRunner is waiting for some response from
the MTA, and that response isn't coming because somehow the SMTP
session has gotten out of sync.


If your Python is at least 2.4.x, you can follow the instructions for
modifying Mailman/Handlers/SMTPDirect.py to produce more debugging
output in Mailman's error log which may help you find more. Do not do
this with Python 2.3.x for the reason mentioned in the FAQ.

Mark Sapiro <mark at msapiro.net>        The highway is for gamblers,
San Francisco Bay Area, California    better use your sense - B. Dylan

More information about the Mailman-Users mailing list