[Mailman-Users] bin/upgrade has been broken since 2.1.5 (orpossibly longer)

Barry Finkel b19141 at anl.gov
Fri Sep 19 14:46:25 CEST 2008

Knut Auvor Grythe <knut at auvor.no> wrote, in part,

>This week, when attempting to upgrade further to Ubuntu Hardy, with
>Mailman 2.1.9, the upgrade script crashed as soon as it reached one of
>these lists, without releasing the lock. The attached patch is what I
>used to be able to upgrade cleanly from the previously corrupted data.

Are you installing from source or using the Debian/Ubuntu package?
If the latter, remember that there are a number of Debian/Ubuntu
patches applied to the source.  When I looked at the patches, I
was not sure what many of them did, and I was not sure of the code
base upon which these patches were built.  IIRC, one patch referred
to 2.1.4 code.  That is why I built my own package from the SourceForge
source; my management would not let me install the source without a
Barry S. Finkel
Computing and Information Systems Division
Argonne National Laboratory          Phone:    +1 (630) 252-7277
9700 South Cass Avenue               Facsimile:+1 (630) 252-4601
Building 222, Room D209              Internet: BSFinkel at anl.gov
Argonne, IL   60439-4828             IBMMAIL:  I1004994

More information about the Mailman-Users mailing list