[Mailman-Users] [Mailman-Announce] Mailman 2.1.12rc1 Released

Mark Sapiro mark at msapiro.net
Mon Jan 12 19:39:24 CET 2009

Mark Sapiro wrote:

>I am happy to announce the first release candidate of Mailman 2.1.12. 
>Mailman 2.1.12 is a minor bug fix and Python 2.6 compatibility release.
>The minimum Python for this release is Python 2.4 and it is compatible
>with Python through 2.6. The previous Mailman releases are not
>compatible with Python 2.6.

I have discovered a compatibility issue between Mailman 2.1.12rc1 and
Python 2.4. As a result of the Python 2.6 compatibility changes, we no
longer install the email 2.5.8 package in Mailman's pythonlib if
Python's email version is greater.

This creates a problem when Python's email is 3.0.1 which is the Python
2.4 package. There is no problem with the email 4.0.x packages in
Python 2.5+.

The following patch to Scrubber.py works around the incompatibility and
will be included in subsequent 2.1.12 releases.

=== modified file 'Mailman/Handlers/Scrubber.py'
--- Mailman/Handlers/Scrubber.py        2008-12-01 04:30:43 +0000
+++ Mailman/Handlers/Scrubber.py        2009-01-12 17:45:14 +0000
@@ -1,4 +1,4 @@
-# Copyright (C) 2001-2008 by the Free Software Foundation, Inc.
+# Copyright (C) 2001-2009 by the Free Software Foundation, Inc.
 # This program is free software; you can redistribute it and/or
 # modify it under the terms of the GNU General Public License
@@ -167,6 +167,9 @@
     # message by a text (scrubbing).
     del msg['content-type']
     del msg['content-transfer-encoding']
+    if isinstance(charset, unicode):
+        # email 3.0.1 (python 2.4) doesn't like unicode
+        charset = charset.encode('us-ascii')
     msg.set_payload(text, charset)

Mark Sapiro <mark at msapiro.net>        The highway is for gamblers,
San Francisco Bay Area, California    better use your sense - B. Dylan

More information about the Mailman-Users mailing list