[Mailman-Users] Private archive nightmare with vhosts

UGSD underground.sd at gmail.com
Mon Feb 1 20:38:28 CET 2010


> I fixed the archiving for both private and public archives so no
> rewriting is involved. private.py does the right thing with my
> additional patches. I also patched the GetBaseArchiveURL() method to
> include the virtual host directory in the public archive URL.
> Finally, I had an issue which almost caused me to give up in disgust.
> The original patch adds a _GetURLHost() function to Mailman.Utils.py
> which gets the host name from the invoking URL. This got the name from
> the SERVER_NAME environment variable which is not the preferred place
> and is different from the URL host in my test environment. It should
> use HTTP_HOST.
> The bottom line for me now is I can take a 2.1.13 base distribution,
> patch it with the patch at
> <http://www.msapiro.net/mm/2.1.13_vhost.patch> and patch that with the
> vhost_extra_patch.txt patch attached to this post, and I think that
> list creation and the web interface work. I haven't tested posting
> because my testbed uses Exim, but I think it should work.

Thank you sooo much!  Both of these patches worked perfectly and now i have a working, 
fully virtual mailman installation. This is not something i would've been able to figure out of my own. 
The only thing it complained about is --with-mail-gid. My previous installation attempts worked fine with 
--with-mail-gid=list, but this time it complained that it needs --with-mail-gid=nobody, but that was an easy fix.

Thanks again, Mark. I really appreciate your help and I am sure that many other users would 
benefit greatly from these 2 patches.

- Igor

More information about the Mailman-Users mailing list