[Mailman-Users] Mailman Archives page not updating

LexIcon unpublishednumber at gmail.com
Thu Mar 18 17:39:52 CET 2010

Mark Sapiro wrote:
> Then the recent posts are probably not in the
> archives/private/LISTNAME.mbox/LISTNAME.mbox file, perhaps because of
> some permissions error. If that is the reason, they are probably all
> shunted and in the shunt queue. If so, you will find error messages
> and tracebacks in Mailman's error log and running bin/unshunt will
> probably archive the messages assuming the permissions or whatever
> issue has been fixed.

Ah! I was relying on check_perms and did not look directly at the error

Ok, so I ran...

chown -hR mailman private/

... and changed the owner of everything in there to the mailman user. I
then ran...


... which took a long time to process, and then I ran...

./arch listname

... which did not seem to have resolved the issue, so I ran...

[root at domain bin]# ./arch --wipe listname

... which resulted in ...

Traceback (most recent call last):
  File "./arch", line 200, in ?
  File "./arch", line 177, in main
  File "/usr/lib/python2.4/shutil.py", line 155, in rmtree
    onerror(os.listdir, path, sys.exc_info())
  File "/usr/lib/python2.4/shutil.py", line 153, in rmtree
    names = os.listdir(path)
OSError: [Errno 2] No such file or directory:

... and I checked the error logs again and found...

Feb 20 21:37:10 2010 (9826) Archive file access failure:
[Errno 13] Permission denied:
Feb 20 21:37:10 2010 (9826) Uncaught runner exception: [Errno 13]
Permission denied:
Feb 20 21:37:10 2010 (9826) Traceback (most recent call last):
  File "/usr/lib/mailman/Mailman/Queue/Runner.py", line 112, in _oneloop
    self._onefile(msg, msgdata)
  File "/usr/lib/mailman/Mailman/Queue/Runner.py", line 170, in _onefile
    keepqueued = self._dispose(mlist, msg, msgdata)
  File "/usr/lib/mailman/Mailman/Queue/ArchRunner.py", line 73, in _dispose
  File "/usr/lib/mailman/Mailman/Archiver/Archiver.py", line 200, in
  File "/usr/lib/mailman/Mailman/Archiver/Archiver.py", line 169, in
    mbox = self.__archive_file(afn)
  File "/usr/lib/mailman/Mailman/Archiver/Archiver.py", line 157, in
    return Mailbox.Mailbox(open(afn, 'a+'))
IOError: [Errno 13] Permission denied:

Feb 20 21:37:10 2010 (9826) SHUNTING:

... so no March errors, and I'm still not getting anywhere.

- Lex

More information about the Mailman-Users mailing list