[Mailman-Users] bug adding user, and archiving gets "shunted"

Mark Sapiro mark at msapiro.net
Fri Apr 1 17:30:00 CEST 2011

Lucio Chiappetti wrote:

>On Thu, 31 Mar 2011, Mark Sapiro wrote:
>> This error is due to one of several known incompatibilities between
>> Mailman versions older than 2.1.12 and Python 2.6 or later. See the
>> FAQ at <http://wiki.list.org/x/pYA9>.
>I read the FAQ, which was however last updated in 2009.

Yes, but the key part in this case is

"Update - March 2009: Mailman 2.1.12 has been released and requires
Python 2.4.x or later. It is the *first* Mailman release compatible
with Python 2.6." (emphasis mine).

>This MIGHT not be a problem, because I'm running tests (as a sort of power 
>user) on my machine (suse 11.3 installed last december), but this is NOT 
>the target system. I'm pretty sure the target system will have suse 11.4 
>which came out recently.
>suse 11.3 bundles mailman 2.1.11-13.2 and python 2.6.5-2.11 (however they 
>provide separately mailman 2.1.14-21.1 and python 2.7-43.1)
>suse 11.4 bundles mailman 2.1.14-4.7.1 and python 2.7-8.2 (and provides 
>also 2.7-43.1)
>I am really confused by all these minor subsubversions.

Everything to the right of the hyphen (-) is a designation by the
packager of build, patch level, whatever. Only suse can tell you what
it means.

I strongly suggest that for a fair test, you upgrade the Mailman on
your test platform to the 2.1.14 package. The suse 11.3 bundle has the
compatibility issues you have already seen and others as well.

>Is the suse 11.4 mm/python coupling sound ?

It should be, but I don't think the combination of Mailman 2.1.14 and
Python 2.7.x has seen much use, so there may be as yet undiscovered

>If so I will tell our sysadm to proceed, and pass on my test experience.
>I might do a few further tests on my machine and occasionally report 
>problems here (be free to reply "usual 2.1.11/2.6 incompatibility").
>Eventually I could upgrade mailman on my test machine (but not python)
>if that is likely to work (just to test also the upgrade procedure).

I would recommend that.

>> If suse is packaging Mailman 2.1.11 with the Python 2.6.5 that you are 
>> apparently using, this is a serious suse packaging problem.
>I could report a bug, however if their 11.4 packaging is sound, they are 
>likely to consider it irrelevant.

I suggest you report it anyway, if for no other reason than to document
the issue with suse.

Mark Sapiro <mark at msapiro.net>        The highway is for gamblers,
San Francisco Bay Area, California    better use your sense - B. Dylan

More information about the Mailman-Users mailing list