[Mailman-Users] Mailman error: Forbidden: You don't have permission to access /pipermail/grads/ on this server [SOLVED]

Tom Browder tom.browder at gmail.com
Tue Aug 2 13:31:33 CEST 2011

On Sun, Jul 31, 2011 at 13:08, Mark Sapiro <mark at msapiro.net> wrote:
> Tom Browder wrote:
>>However, I, as a list user, cannot get access to the archives for a
>>list.  When I try to look at the archives through the link on the
>>Welcome message I get the following:
>>  Forbidden
>>  You don't have permission to access /pipermail/grads/ on this server.
>>I tried changing the example line in the mailman.conf  file from:
>>  Alias /pipermail/ /var/lib/mailman/archives/public/
>>I have searched this list for "pipermail" but see no similar problem.
>>I'm sure I've missed a note somewhere but I'm not sure how to proceed.
>> The mailman docs talk about permissions and the mailman user but
>>Ubuntu installs all mailman files with root:list ownership which seems
>>to work for all else.  All the directories under /var/lib/mailman have
>>these permissions:
>>  drwxrwsr-x  4 root list
> If that includes /var/lib/mailman/archives/private, then that's OK.
> Otherwise note that /var/lib/mailman/archives/private must be o+x or
> must have user:group xxx:list where xxx is the user that the web
> server uses to access files.

Aha, I missed the fine details of one important directory: the
archives/private directory did not have these permissions:

  drwxrwsr-x  4 root list

Instead it had these:

  drwxrws---  4 root list

As root I excuted

  chmod o+xr private

and now all works as advertised!

Thanks a heap, Mark.  I shall file a bug with Ubuntu.

Best regards.


Thomas M. Browder, Jr.
Niceville, Florida

More information about the Mailman-Users mailing list