[Mailman-Users] Permissions on Mailman Archive Directory

Barry Finkel bsfinkel at anl.gov
Thu Feb 17 22:03:42 CET 2011

I have a question about permissions for the archive directory.
I am migrating my Mailman server from an Ubuntu Dapper server
on which I installed my own package, built from the SourceForge
source, to an Ubuntu Lucid server, where I am installing the
Ubuntu/Debian package.  The directory in question is


On my production Dapper server, I have

      drwxrws--x 904 www-data list 24576 2011-02-09 14:17 .

On my test Lucid server I have

      drwxrws--- 10 root list 4096 2011-02-17 11:19 .

There are two differences:

      owner: www-data vs. root
      group execute privileges

In the current configuration I cannot get from the web to the list
archives.  I tried changing the ownership to www-data, and that worked.
I then reset the owner back to root and added group execute
privileges, and that also worked.

What is suggested as the preferred fix?  Thanks.
Barry S. Finkel
Computing and Information Systems Division
Argonne National Laboratory          Phone:    +1 (630) 252-7277
9700 South Cass Avenue               Facsimile:+1 (630) 252-4601
Building 240, Room 5.B.8             Internet: BSFinkel at anl.gov
Argonne, IL   60439-4828             IBMMAIL:  I1004994

More information about the Mailman-Users mailing list