[Mailman-Users] error on attempting t start mailman

Steven Jones Steven.Jones at vuw.ac.nz
Fri Jun 3 00:58:26 CEST 2011

Fixed the first one.....tried restarting, same message.....did the second with -f which fixed ownerships (I have a case into Red Hat on this...
but it still wont start.

PREFIX  = /usr/lib/mailman

VAR_PREFIX = /var/lib/mailman

I think these are correct....


From: Mark Sapiro [mark at msapiro.net]
Sent: Friday, 3 June 2011 8:54 a.m.
To: Steven Jones
Cc: mailman-users at python.org
Subject: Re: [Mailman-Users] error on attempting t start mailman

On 6/2/2011 12:55 PM, Steven Jones wrote:
> So the file is there.....how to I get it to "find it" again....?
> Also I suspect its the same with all the lists.....

Probably it is all lists.

The first thing mailmanctl does is set its user and group to those of
Mailman. So there are two possibilities. Either 'mailman' doesn't have
sufficient access to even 'see' /var/lib/mailman/lists/*/config.pck.

The permissions and ownership on /var/lib/mailman should be

drwxrwsr-x   mailman mailman

check that, and if that doesn't solve your issue, run Mailman's
bin/check_perms -f as root.

If that still doesn't solve it, look at Mailman/Defaults.py for the
definition of PREFIX and VAR_PREFIX to ensure they are what you think
they are.

Mark Sapiro <mark at msapiro.net>        The highway is for gamblers,
San Francisco Bay Area, California    better use your sense - B. Dylan

More information about the Mailman-Users mailing list